GeoHot: No Solution For Firmware 3.1.3 On Newer Devices Or Baseband 05.12.01

This is what GeoHot has tweeted after the release of new iPhone OS 3.1.3:

“There is no solution for 3.1.3 on newer devices or 05.12.01 There is no untethered jailbreak. I don’t know if/when these things will exist.”

Means GeoHot is not working on firmware 3.1.3 jailbreak/unlock. Indeed a sad news for all those who rushed to update the latest iPhone firmware 3.1.3 or accidentally did it and now waiting to jailbreak their newer iDevices (iPhone 3GS, Newer iPod Touch-MC, iPod Touch 3G) or unlock iPhone 3.1.3 (3GS and 3G).

You might know that we can jailbreak iPhone 3G, iPhone 2G, iPod Touch 1G with RedSn0w 0.9.2 and iPod Touch 2G (Non-MC) with the RedSn0w 0.9.4 but there’s no solution out there to unlock iPhone 3.1.3 because firmware 3.1.3 updates the Baseband to 05.12.01. I’m afraid to say this but I do not see any jailbreak/unlock update coming for 3.1.3 firmware, we will¬† soon be getting iPhone OS 3.2???

Jailbreak Firmware 3.1.3:

You can follow us to Twitter and Subscribed to RSS Feed to receive latest updates on iPhone jailbreak and unlocking stuff.

2 comments… add one
vesh February 14, 2010, 11:31 pm

i accidently upgrade the new version 3.1.3(7E18) with modem firmware05.12.01 in my iphone 3gs from itunes. now i cannot use my iphone anymore because my iphone get lock after downloading new version. i cannot use my simcard. it says your simcard is invalid. how can i unlock my iphone. please help me ..

MCash February 25, 2010, 8:40 pm

I’ve done the same, we can only wait for Geohot to release it.

Leave a Comment