UltraSn0w 1.2.5 iPhone Unlock Updated for iOS 5.0.1

The iPhone Dev Team has released an update to UltraSn0w, the iPhone unlock. The new UltraSn0w 1.2.5 supports iOS 5.0.1 on older supported basebands.

Hit the jump to learn more about UltraSn0w 1.2.5…

iPhone Dev Team’s iPhone 4, 3G, and 3GS software unlock, now with added PwnApple. Compatible with iPhone 4 baseband 01.59.00 and iPhone 3G/3GS basebands 04.26.08, 05.11.07, 05.12.01, 05.13.04 and 06.15.00! Thanks to @sherif_hashim and @Oranav for contributing baseband crashes.

Supported Baseband

How to: check iPhone baseband

iPhone 3GS: 04.26.08 – 05.11.07 – 05.12.01 – 05.13.04 – 06.15.00
iPhone 4: 01.59.00

IMPORTANT: 3GS old-bootrom users please apply latest redsn0w 0.9.9b9d before installing ultrasn0w compatibility update.

iPhone3GS owners in our comments section below noticed a problem with the untethered jailbreak available for the old-bootrom 3GS. We’ve corrected that problem in 0.9.9b9d. If you have an old-bootrom 3GS and have already used last night’s redsn0w on it, you can re-run it again without losing anything. Just use this new version, go to Extras->IPSW and manually select the 5.0.1 IPSW, then go back and Jailbreak it again (but you can uncheck Cydia because it’s already installed).

Don’t forget to hit the +1, Like and/or Tweet button if you like the post. You can follow us on  Google Plus, Twitter (@iphone_heat), Facebook (iPhoneHeatDotCom), and Subscribe to RSS Feed to receive latest updates.

21 comments… add one
Bhamla December 25, 2011, 2:36 pm

Ultrasn0w 1.2.5 DOESN’T UNLOCK 3GS baseband 06.15.00, I have tried it, Now What? I am held up What do I do next? Please Help!!!!!!!!!!!!

travissvedberg January 2, 2012, 7:49 am

uninstall it from cydia.. should return ur phone back to normal

dhrumil December 25, 2011, 9:53 pm

i update in my iPhone 3gs its not working NETWORK Gone help my….i want to downgrade ultrasn0w…HELP… HELP…. HELP

dhrumil December 25, 2011, 9:54 pm

i update in my iPhone 3gs its not working NETWORK Gone help my….i want to downgrade ultrasn0w…HELP… HELP…. HELP

dhrumil December 25, 2011, 9:56 pm

i update in my iPhone 3gs version 4.3.3 its not working NETWORK Gone help my….i want to downgrade ultrasn0w…HELP… HELP…. HELP

dhrumil December 25, 2011, 9:56 pm

iphone version 4.3.3

dhrumil December 25, 2011, 9:58 pm

how to downgrade ultrasn0w ???????????

dhrumil December 25, 2011, 10:03 pm

thanks its working after restarting…Thank u so much

dhrumil December 25, 2011, 10:03 pm

we love u

Shahbaz Khan December 27, 2011, 9:20 am

Thanks for support.

Bhamla December 28, 2011, 2:07 am

Sorry for myself, I had tried redsn0w 0.9.9b9d the very day it was released, and even right now!!!!!!! It didn’t unlock my Iphone 3GS IOS 5.0.1 Base Band 06.15.00 please help111111111

aftabifi December 29, 2011, 2:34 pm

I have update my iPhone 3GS and jailbeak with 0.9.10b2. Now i m unable to unlock it with ultrasnow . my baseband is 6.15.00

01.59.00 December 29, 2011, 7:53 pm

I am running iOS 4.3.3 bb 01.59.00, will the update change anything? Please reply promptly.

read December 30, 2011, 3:04 am

use snowbreeze or redsnow to update your firm ware . Don’t update through itune . Itune will update your baseband and you won’t be able to unlock.

blackroses_ir January 2, 2012, 8:59 am

Im running ios 5.0.1 3gs with 6.15.00 baseband and now I have no service how can I downgrade ultrasnow?
please help me

omtane January 11, 2012, 9:35 pm

Ultrasn0w 1.2.5 DOESN’T UNLOCK 3GS baseband 06.15.00, I have tried it, Now What?

DJYT January 13, 2012, 1:16 am

any body knows how to UNLOCK 3GS baseband 06.15.00, on 5.0.1 ??

DJYT January 27, 2012, 3:02 am

the solution its to flash again the Ipad BB on the 3gs, and it will work fine. to fix push just instal SAM

good luck

Tuniko January 23, 2012, 1:11 pm

I never see something like that, i try unlock my client Iphone 3gs Ios 5.0.1 with the baseband 05.16.05 and no body help me! hoouchh, in this moment i have the redsn0w 0.9.10.b4 for Windows and it work and install cyndia but don’t put the repo666, wat i need to do my friends?

Diako January 26, 2012, 2:21 pm

I have a Iphone 3GS with 05.11.07 Firmware and UltrasnOw doesn’t work. It can’t unlock the mobile. Any ideas?

oms August 13, 2012, 7:29 am

i have an iphone 4g,4.10.01firmware downloaded ultrasnow 1.2.7, does not work pls help

Leave a Comment