TinyUmbrella 04.02.09: Preserves iPhone 4 Baseband, Supports iTouch 4G iOS 4.1 - iPhoneHeat

TinyUmbrella 04.02.09: Preserves iPhone 4 Baseband, Supports iTouch 4G iOS 4.1

TinyUmbrella has been updated to version 04.02.09 in anticipation of the imminent release of iOS 4.1. You can download TinyUmbrella 04.02.09 from the links below.

Download links and some notable features in TinyUmbrella 04.02.09 after the jump…
tinyumbrella

  • Baseband Protection – Updating to 4.1 using TinyUmbrella will protect your baseband from update. THIS ONLY APPLIES TO IPHONE 4!!!!! If you have a 3G or 3GS and you update to 4.1 your baseband will likely be updated.
  • SHSH Retrieval from Cydia – If you don’t have your SHSH locally, TinyUmbrella will request them from Cydia on-demand; allowing the restore to continue
  • Automatically point hosts to Cydia – Once you close TinyUmbrella, it points your hosts file to Cydia (for further baseband protection and update/restores without TinyUmbrella)
  • iPod Touch 4G 4.1 support 🙂

IMPORTANT: Do not update to iOS 4.1 if you wish to keep your unlock and jailbreak. The baseband protection only applies to iPhone 4. It’s a small yet very important note. 3G and 3GS phones are excluded.

Download TinyUmbrella 04.02.09

You can download TinyUmbrella 4.02.09 from the link below:

How to Save SHSH blobs

A detailed guide on how to save SHSH blobs for iPhone, iPad and iPod Touch is linked below:

You can follow us on Twitter, Join us at Facebook, and also Subscribed to RSS Feed to receive latest updates.

5 comments… add one
Bait1972 September 8, 2010, 7:06 pm

Can you jailbreak iPhone if it come 4.0.2 please email it [email protected] yahoo.com thanks

madhu March 25, 2011, 10:25 pm

how to Download TinyUmbrella pls help me iphone3gs update than 4.3

gbon_bd October 2, 2011, 8:01 pm

My iPhone 4 currently in DFU mode. I tried to update my ios from 4.2.1 to 4.3.3 with snowbreeze 2.7.3. But when i restore custom firmware an unknown error occurred (3195). My baseband was 03.10.01. I am afraid may be I choose wrong option. Is there any process to solve my problem? Can I upgrade my baseband so i can unlock with ultrasnow.. ?

Leave a Comment