Dev-Team Releases RedSn0w 0.9.8b2 to Jailbreak iOS 5 Beta 3

Dev-Tem has released RedSn0w 0.9.8b2 to jailbreak iOS 5 beta 3. RedSn0w 0.9.8b2 can jailbreak iOS 5 beta 3 on iPhone 4, 3Gs, iPod Touch 4G, 3G and iPad 1. You can download RedSn0w 0.9.8b2 from below..


RedSn0w 0.9.8b1 is capable of jailbreaking iOS 5 beta 3 by pointing RedSn0w to beta 1 IPSW, however, an unexpected issue surfaced. After jailbreaking with RedSn0w 0.9.8b1 some of the app store applications were not running properly. So, RedSn0w 0.9.8b2 is out to fix this issue.

This is what MuscleNerd tweeted about the RedSn0w 0.9.8b2 release:

We’ve update redsn0w to account for the sandbox changes that affected App Store apps in 5.0b3 (and it now recognizes the IPSWs for all three betas so far). If you already jailbroke 5.0b3 using the previous redsn0w, you don’t need to re-jailbreak…just use this updated version to boot tethered. Start pointing redsn0w at the 5.0b3 IPSW starting with 5.0b3.

MuscleNerd: “redsn0w 0.9.8b2 http://is.gd/6eek4Y should fix 50b3 App Store issue (if you’re already JB, just use this to boot tethered)”

It means, if you’ve already used b1 to jailbreak iOS 5 beta 3, simply use the RedSn0w 0.9.8b2 to tether boot and everything should work fine.

Steps to jailbreak iOS 5 with RedSn0w 0.9.8b2 are exactly similar to the guide posted earlier. RedSn0w 0.9.8 download links and step-by-step instruction are links below..

Download RedSn0w 0.9.8b2

Download RedSn0w 0.9.8b2
Download iOS 5 beta 3
Download iTunes 10.5 beta 3

Jailbreak iOS 5

How to: Jailbreak iOS 5 on iPhone 4, 3GS, iPad, iPod Touch with RedSn0w 0.9.8b
How to: Jailbreak iOS 5 with Sn0wbreeze 2.8
How to: Jailbreak iPhone 3GS (Old BootRom) iOS 5 with Sn0wBreeze 2.8 [Untethered]

2 comments… add one
bob your uncle July 14, 2011, 12:38 am

Don’t use doesn’t work cydia fails to open.

solid648 July 23, 2011, 1:22 am

it does work. cydia opens and installous works as well. when i first installed and jail broke, multitask did stop functioning but after a restore and jailbreak, it started working again. Make sure you use red snow 0.9.8b2 not b3

Leave a Comment