Unlock iOS 4.3.1 with UltraSn0w 1.2.1 [iPhone 4, 3GS]

UltraSn0w 1.2.1 has been fixed to unlock iOS 4.3.1 on previously unlockable Basebands. These are the steps to unlock iOS 4.3.1 with UltraSn0w on iPhone 4 and iPhone 3GS. Before unlocking iOS 4.3.1 on iPhone 4 and iPhone 3GS, read the important part first.

We’ve pushed out the 4.3.1 compatibility fix for ultrasn0w in Cydia — it’s now at version 1.2.1. If you’re not already at 4.3.1 and you need the unlock, please be sure you understand how to get to 4.3.1 using a custom IPSW that doesn’t update your baseband.

This isn’t a new unlock! It’s to allow those who are already unlocked to use FW 4.3.1. It also fixes the signal bar issue for those who aren’t using the unlock but retain an older baseband intentionally.

AFTER INSTALLING ULTRASN0W 1.2.1, PLEASE REBOOT YOUR iPHONE using the normal “slide to power off” swipe. T-Mobile users in the USA also should disable 3G mode in Settings->General->Network.

Important

  • iOS 4.3.1 had broken the UltraSn0w. This UltraSn0w update just fixes the conflicts with iOS 4.3.1. There’s nothing new.
  • No Newer Baseband support is added.
  • Compatible Basebands: 01.59.00 | 04.26.08 | 05.11.07 | 05.12.01 | 05.13.04 | 06.15.00
  • Not-Compatible Basebands: 02.10.04 | 03.10.01 | 04.10.01 | 05.14.02 | 05.15.04 (Dev-Team is working on Downgrade Baseband method)
  • iPhone 3GS (not-compatible baseband) users can upgrade to 06.15.00 baseband which is unlockable (Here is How to). Upgrading your iPhone 3GS baseband to the 06.15.00 iPad baseband hack to unlock MAY cause you to lose your GPS!

Let’s Unlock iOS 4.3.1 with UltraSn0w Unlock on iPhone 4 and iPhone 3GS.

How to Unlock iOS 4.3.1 with UltraSn0w

***T-Mobile USA users please disable 3G network first. (Settings >General >Network and turn the “Enable 3G” switch to OFF.)

Your iPhone 4 or iPhone 3GS must already jailbroken on iOS 4.3.1. Jailbreak iOS 4.3.1 guides are linked at the bottom.

Assuming that your iPhone 4 or 3GS is jailbroken on iOS 4.3.1;

  1. Open the Cydia;
  2. Let the Cydia Load and Update if it prompts you;
  3. Go to Search tab and search for ultrasn0w and install it.
  4. Installing UltraSn0w will unlock iPhone 4 or iPhone 3GS iOS 4.3.1 with baseband 01.59.00 / 04.26.08 / 05.11.07 / 05.12.01 / 05.13.04 / 06.15.00. Once the installation is completed, reboot your iPhone.

unlock ios 4.3.1 ultrasn0wunlock ios 4.3.1 ultrasn0wunlock ios 4.3.1 ultrasn0w

Voila! You have unlocked iOS 4.3.1 on iPhone 4 / 3GS with UltraSn0w and can use SIM from any carrier now.

How to Jailbreak iOS 4.3.1

Also checkout:

55 comments… add one
sowat99 April 10, 2011, 3:59 pm

Will this update not conflict with older iOS’s? Is this update only for 4.3.1? Im currently at iOS 4.0.1 and bb 1.59.00?

xevy April 10, 2011, 4:17 pm

yes it worked… thnks L TRA SN0

egbm87 April 10, 2011, 6:14 pm

Quick question…

I have an iPhone4 under version 4.1 and baseband 02.10.04. If I upgrade to any higher version would I be able to unlock it?

thx

eziely April 13, 2011, 12:01 pm

@egbm87 if you upgrade to a higher version that will only upgrade your current FW to the latest FW which is not unlockable at the moment.

You’ll have to wait for the DEV team to crack or figure out the current FW to have an unlock.

What would be best is not to update your current ios. Just be patience and don’t push the dev-team.

Thanks

alex April 10, 2011, 7:13 pm

Will it fix the signal bar issue on baseband 02.10.04 on a jailbroken iPhone 4 v4.3.1? I’m not looking to unlock it, just to fix the signal bar.
Thanks!

iPhoneHeat April 11, 2011, 12:04 am

Yes, fist go to Changes tab in Cydia and see if any update is available.

alex April 11, 2011, 1:00 am

Thanks, worked like a charm!

hamiexz April 10, 2011, 7:18 pm

waiting for the last 5 month 02.10.04 baseband unlock!!!!

james95121 April 10, 2011, 10:16 pm

I don’t want the unlock just want to fix the signal bars issue should I still intall ultraslow ?

ankis April 11, 2011, 12:25 am

Hello!!
Ultrasn0w 1.21 work Fine in my iPhone 4 FW 4.3.1 (1.59.00) Full signal !!
Thanks !!!!

des23mond April 14, 2011, 9:59 am

hey mines not working says no service

MNFL April 15, 2011, 9:48 pm

i have i4 4.3.1 but with baseband 04.10.01 and not working 🙁 no service! -,-

tee April 11, 2011, 9:36 pm

ugh, ONCE AGAIN…Wheres the unlock for the 3.10???

drchandoo April 12, 2011, 12:02 pm

unlock for firmware 5.16.02 3gs 4.3.1

buttcheek10 October 26, 2012, 4:23 am

when i hit the ipsw that i want to down load it says that i wont work because its not combatible wit my ipod. What should i do

buttcheek10 October 26, 2012, 4:26 am

I have the 3g itutch and i did all the steps but after i click restore wile holding dow shift alt and the windoes button and i click on the ipsw it says not combatible .tell me wat to do

mealraisi April 13, 2011, 2:42 pm

any update if there will be unlock for baseband 02.10.04 | 03.10.01 | 04.10.01 | 05.14.02 | 05.15.04 soon

Please Advise

Queenofhearts April 19, 2011, 3:22 am

I’m looking for 5.14 too. I read that instead of unlocking 5.14 they’re working on downgrading from the ipad fw…

The Jailbreaker April 13, 2011, 2:48 pm

any solution how to downgrade Iphone4 IOS 4.1 Baseband 02.10.04 to 01.59.00

Ansari April 13, 2011, 10:07 pm

I am currently using iPhone 3GS 4.0.1 firmware 05.13.04 and it is unlocked and using on tmobile. I want to upgrade to 4.3.1 will it update my firmware if go from 4.0.1 to 4.3.1?? Thanks

Queenofhearts April 19, 2011, 3:19 am

I think you’ll be ok if you use custom ipsw.

altaf April 14, 2011, 5:23 am

how i can unlock baseband 04.10.01 please help me out for this

MNFL April 15, 2011, 9:43 pm

Yes please… 04.10.01 unlock! when?

Godfred30 April 14, 2011, 12:52 pm

Iphoneheat if you say its has been updated to fix previously unlockable baseband,i think you are misleading,this ultrasn0w DOES NOT unlock any previously unlocable baseband according to the Dev-Team.

dan April 14, 2011, 1:36 pm

I got 3gs os 4.1 bb 06.15. When i try to update to os 4.3.1 i got 1015 error. Can anyone help? Thx

dan April 14, 2011, 1:41 pm

got iphone 4 with os 4.2.1 bb 03.10. if i upgrade to 4.3.1 can i unlock it? Pls help. Thx

MNFL April 14, 2011, 2:37 pm

When will there be an UNLOCK for iPhone4 IOS 4.3.1 Baseband 04.10.01?? i urgently need it, please, anybody…!?

MNFL April 14, 2011, 2:37 pm

When will there be an UNLOCK for iPhone4 IOS 4.3.1 Baseband 04.10.01?? i urgently need it, please, anybody…!?

eric April 15, 2011, 6:32 am

How will I fix internet tmobile usa?

yamin April 15, 2011, 10:17 am

Would you please give us an update on when or if BB 3.10.01 will be unlocked? we’re dying here.

MNFL April 15, 2011, 9:54 pm

please, anyone, baseband unlock 04.10.01? 🙁

Giel April 16, 2011, 6:49 pm

I have a 3GS 4.3.1 BB 06.15.00
I have installed ultrasn0w 1.2.1
and there’s still no signal
Can someone please help me.

shaufan April 18, 2011, 3:02 am

Please unlock iphone 4 bb 04.10.01!!+

thanks

MNFL April 18, 2011, 5:27 pm

yea please, anyone!

drchandoo April 18, 2011, 1:06 pm

any solutions to unlock baseband 05.16.02?
guys please help me up

Queenofhearts April 19, 2011, 3:15 am

Ok I need help to unlock. 3GS, jailbroken w/green poison. V: 4.1, BB: 5.14.02. I never upgraded b/c there wasn’t unlock for them & I never switched to ipad cuz it sounded stupid to give up GPS etc. So in order to use this ultrasnow I either have to upgrade to 4.3.1 or change to 6.15 just so I can downgrade to something unlockable? I know I need to change my bb, is there a list of each version of FW w/their BB & whether can be jailbroken & unlocked? Links to needed how to’s would be fab.

pics999 April 20, 2011, 1:43 pm

what is your baseband?? most likely you could jailbreak with snowbreeze to 4.3.1 and still keep your same baseband , then just install ultrasnow … thats what i did on my 3gs the other day and all is good …..

Queenofhearts April 26, 2011, 12:48 am

I have baseband 5.14.02

QueenOfHearts May 7, 2011, 11:44 pm

Will ultrasnow work on BB 5.14? I thought it didn’t?

kikyoamy May 5, 2011, 9:56 am

It worked but does it work immendiemty and detect the sim or not,
becuase on my iphone 3gs it kept saying searching….and then it said no service???help??

hardeep singh May 6, 2011, 3:51 pm

I followed the procedure above but it gives me restricted network.
When I uninstall ultrasn0w from my phone then it reverts back to the single bar signal issue.

Please help

hardeep singh May 6, 2011, 4:34 pm

my baseband is 6.15

ahmed August 3, 2011, 5:31 pm

thanks for every thing

marco August 25, 2011, 9:37 pm

im on 4.3 i jailbroke with jailbreakme.com my b.b. 1.59.00 i installed ultrasn0w 1.2.3 ,i rebooted,i reseted my network setting snd i sill have no signal dont know what to do.

Leave a Comment