Install Flash on iPhone 4 (Frash for iPhone 4)

Frash, the Flash for iPhone/iPad, is now ready for iPhone 4. The iPhone 4 version of Frash is compiled by Grant Pannell. In this Guide, you’ll learn how to install Flash on iPhone 4. Follow the steps below to install Flash (aka Frash) on iPhone 4.

flash iphone 4If you’ve got an iPad, we have already posted a guide on Frash for iPad which can be found here:

How to: install flash on iPad

NOTE:

Disclaimer: This guide for educational purposes only. So, try it at your own risk. We can NOT be held responsible if anything goes wrong.

How to Install Flash on iPhone 4

Assuming that your iPhone 4 is already jailbroken:

  • Open the Cydia.
  • Go to manage Tab at bottom.
  • Hit the big Sources button.

install flash on iphone 4

  • Hit the Edit button on Top-Right
  • Then Hit the Add button on Top-Left
  • Then Enter the following URL: http://repo.benm.at/ and hit the Add Source button.

install flash on iphone 4

  • Once the Source is added to the Cydia, hit the big return to Cydia button at bottom of the screen and then Done button.
  • Go to Search tab and search for Frash and install it.
  • You can also install Frash Toggle. This will let you enable/disable Frash via SBsettings toggle button.

install flash on iphone 4install flash on iphone 4

install flash on iphone 4install flash on iphone 4

Also checkout:

You can follow us on Twitter, Join us at Facebook, and also Subscribed to RSS Feed to receive latest updates.

24 comments… add one
zezius August 10, 2010, 5:03 pm

Only to IPHONE 4? Not 3g? 3gs?

Monisnerddy August 10, 2010, 5:59 pm

I have i phone 4 and still not working. It just show a grey box written “flash” 🙁

PyBrick November 16, 2010, 12:51 pm

You have to tap on the gray box labeled Flash and sometimes the flash object will load.

Monisnerddy August 10, 2010, 5:34 pm

It is not working for me 🙁

djmac1003 August 10, 2010, 5:50 pm

works with my 3gs! thx!

didithu August 10, 2010, 6:34 pm

It’s not working on my 3gs

GrDr August 10, 2010, 8:35 pm

Works good with my 3GS 4.0.1! tnx 4 good job:)

sowat99 August 10, 2010, 8:42 pm

yup it works in my i4. If you see the flash blocks, just tap it then the flash material will load up.

sowat99 August 10, 2010, 11:47 pm

works with flash related ads. but went to try it in youtube website, it cant run video. 🙁 i think this flash application has bounderies..

acurawin August 11, 2010, 12:16 am

whats not listed on this site is that it is still in alpha so it needs a lot of work to make better

PyBrick November 4, 2010, 9:31 pm

Aren’t versions that are less than one (Frash 0.02) usually in alpha or beta phases?

AMOLAO August 11, 2010, 5:28 am

WORKING PERFECT IN MY 3GS!!! AT LAST FLASH IN MY IPHONE!!!VERY GOOD!!

jax August 11, 2010, 8:46 pm

WORKING NICE ON MY 3GS… thanks, but its an old news

Zorroedad August 12, 2010, 3:25 am

Works like a charm in my 3GS 32gb
Thanks

David August 12, 2010, 7:59 am

Frash Games when activated gets unexpected error on my 3.1.3 3GS
Frash Toggle requires 3.2 & above.
Probably need to upgrade my FW first 🙁

PyBrick November 4, 2010, 9:29 pm

According to my experience, Frash Toggle won’t even install unless you are running iOS 3.2 exactly. That just seems strange to me.

PyBrick November 4, 2010, 9:27 pm

According to the Frash package information: “Frash doesn’t work for iPhone 2G, iPhone 3G, iPod Touch 1G, and iPod touch 2G.”

When trying to install Frash 0.02 on ipt2g, Cydia tells me that Frash Depends on gsc.armv7 and I can’t install (as expected).

When trying to install Frash Toggle 0.1-4 on ipt2G iOS4.1, Cydia tells me that Frash Toggle requires iPhone Firmware = 3.2 and I can’t install.

Chieftexas November 14, 2010, 12:26 am

Wont let me install the Frash Toggle – Says you need 3.2 firmware. Are you not running IOS 4 on your iphone 4?

PyBrick November 16, 2010, 12:53 pm

For some strange reason, anybody not running iOS 3.2 exactly, not iOS4.x and not iOS3.1.x, can install the Frash toggle. It makes no sense to me.

Liling September 12, 2011, 5:17 pm

I installed but still cant work. The error abort () food something like like.. Why is not wrking please help.

Leave a Comment